Using HSRP On A /30 or /31

From Baranoski.ca
Jump to: navigation, search


It's common for business ISPs to use a /30 as a point-to-point to their customers, then route them a /29 or larger. Normally, using a /30 precludes the possibility of having redundant routers terminating the connection. The common belief is that you need a minimum of a /29 for HSRP: one IP for router A, one for router B, one for the HSRP High Availability address, and the rest for the clients.

In reality, the IPs on router A and B need to be in the same subnet, but it does not need to be the same subnet as the HA address. For example:

  • ISP Gateway: 24.1.1.0/31
  • Customer HA address: 24.1.1.1/31
  • Customer Router A Outside Interface (Fa0): 192.168.0.1/30
  • Customer Router B Outside Interface (Fa0): 192.168.0.2/30


Interface Config

Router A

interface FastEthernet0
 ip address 192.168.0.1 255.255.255.252
 standby 1 ip 24.1.1.1

Router B

interface FastEthernet0
 ip address 192.168.0.2 255.255.255.252
 standby 1 ip 24.1.1.1


Route Config

Routers A and B just need an interface route to be able to direct the traffic to the ISP's gateway, and their default route pointing to the ISP's gateway

Router A

ip route 24.1.1.0 255.255.255.254 fa0
ip route 0.0.0.0 0.0.0.0 24.1.1.0

Router B

ip route 24.1.1.0 255.255.255.254 fa0
ip route 0.0.0.0 0.0.0.0 24.1.1.0